Ryzen 5 randomly freezes on boot


I saw this was an issue and found a few posts on different forums but no real clear way to solve it. Seems like there are a bunch of suggestions out there.

I am dual booting Win 10 and rebornOS. I just purchased the following and installed reborn on a: HP ProDesk 405 G4 Desktop Mini PC with AMD Ryzen 5 Radeon Vega 11

I had issues booting off the USB drive too to install reborn as it would randomly freeze but once inside Linux I was able to run the install fine. But now whenever I boot up (post reborn install) its like 1 out of 6 times or so I can get in without freezing. Attached is an image showing where the freeze happens. So far I have not encountered any freeze while in Linux.

Thank you for taking the time to read and any suggestions are greatly appreciated! FYI, I’m still new at Linux only a 3 month old but glad to be here! :grinning:


I have a question for you: Have you disabled secure boot on your computer?

Another one: What desktop have you installed? If you install GNOME or KDE, both desktops will start by default in Wayland. Try to select X11 when starting either of these two.

I have not found much information about your computer that can help me. On the HP website I have only found a short manual, which has not been of much help to me.


1 Like

@rebornosday You can also check whether you already have the latest BIOS / UEFI for your notebook.

Hey guys,

Thanks for responding. Yes I have secure boot disabled as shown in the attached. I have Gnome installed. Does selecting X11 matter as I can’t even get to the login screen to select these options when it freezes?

Thanks @ron I tried updating via network but bios just got stuck on “configuring network”. I will try to update perhaps another way.

Yes that is a good idea. Most manufacturers offer various options for flashing the BIOS/UEFI.

Alright, just updated the Bios to the latest version via windows HP support assistant but unfortunately the issue remains.

It would be interesting to see the logs whenever you can get in. For example, let us assume you have a few unsuccessful boots and you finally boot successfully. Then after you login, please open the terminal and run journalctl -b -1 > ~/frozen_boot_log.txt. This would pull up logs from the previous boot and store it in a text file. Then you could upload the file frozen_boot_log.txt so that we can try digging it for information :thinking:. Wish you a happy weekend :slightly_smiling_face:

Ok thanks! The forum is only letting me upload images and won’t accept txt files. I tried adding with preformatted text but it’s saying its past the character limit. I uploaded it here:

May you also have a great weekend :grinning:

Hello, just checking in to see if anyone had a chance to look at this or if there were any other ideas?


And if you try the LTS kernel?
Maybe it will be solved with him.

sudo pacman -S linux-lts linux-lts-headers
sudo grub-mkconfig -o /boot/grub/grub.cfg

Restart, select Advanced, on the screen that allows you to select RebornOS to start, and there you choose Kernel 5.10. Maybe with the LTS kernel it works better for you.


Also if you use KDE or GNOME, select X11 for the desktop (not Wayland) …

@Rafael Thanks, I see the following when I login, I don’t see x11?

Also, when I boot up I can select “reborn advanced” options and I have selected LTS there but still the same issue happens. Would the above suggestion you gave with sudo commands do the same thing?

Use GNOME on XORG. GNOME is Wayland… GNOME on Xorg is X11

@Rafael Oh ok gotcha. I tried this and rebooted several times. Unfortunately, the issue persists.

Update: I tried setting “processor.max_cstate=5” and “processor.max_cstate=1” per forum post here: [Solved] Random freezes with AMD Ryzen on Linux 5.0 / Kernel & Hardware / Arch Linux Forums

But still the issue persists