Q:Why is Timeshift Available Only for Live USB/Restore Mode?

Are there issues with TS? Why is it not available to use to set up Rsync or Btrfs back ups?



Hi @scubapro25 , how did you install timeshift?

Wow! That was fast! :slightly_smiling_face:

I believe it came automatically with my installation of Reborn Cinnamon (Kernel: 5.12.9-arch1-1)

Could you try installing the latest patched version using

yay -S timeshift

There was an update just yesterday. Please let me know if this doesn’t work.

Thanks for trying to help, but I installed the patch according to your suggestion and I’m afraid I’m still getting the ‘Live USB Only’ option.

@scubapro25 Could you share the outputs of these? (Run them on a terminal):

pacman -Qi timeshift

pacman -Qi timeshift

[mike@mikey-pc ~]$ pacman -Qi timeshift
Name : timeshift
Version : 20.11.1+3+g08d0e59-3
Description : A system restore utility for Linux
Architecture : x86_64
URL : GitHub - teejee2008/timeshift: System restore tool for Linux. Creates filesystem snapshots using rsync+hardlinks, or BTRFS snapshots. Supports scheduled snapshots, multiple backup levels, and exclude filters. Snapshots can be restored while system is running or from Live CD/USB.
Licenses : GPL
Groups : None
Provides : None
Depends On : gtk3 libsoup cronie rsync libgee vte3 xapp xorg-xhost
Optional Deps : btrfs-progs: BTRFS support [installed]
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 3.82 MiB
Packager : Unknown Packager
Build Date : Mon 19 Apr 2021 11:45:37 AM PDT
Install Date : Mon 07 Jun 2021 08:36:21 PM PDT
Install Reason : Explicitly installed
Install Script : Yes
Validated By : Signature

timeshift-launcher output = timeshift with same options as before, ie: Live USB Restore Only

@scubapro25 As I suspected, it did not update to the latest version. Let us use a different command this time to install the latest version:
yay -Sy timeshift
This should work if it takes from AUR instead of the rebornos repository

I think I realize what is going on. The RebornOS repository might be substituting the AUR version. Let me test a few things and get back to you. The latest version on AUR is 20.11.1+4+gd437358-1 and the RebornOS repository replaces it with an older version with higher priority.

Cool. Thanks, shivanandvp


Tested this and it installs the supposed fixed version from the AUR (20.11.1+4+gd437358-1)

yay -Sy aur/timeshift

I will try to get the RebornOS repository to use the latest version too, soon.

Let me know how this goes :slightly_smiling_face:

Thanks for all your help, shivanandvp!

@scubapro25 Is your problem solved? :slightly_smiling_face:

Sorry for the late reply: problem solved–thanks!

1 Like