Grub crashed itself every other day


just stepped by to test the new RebornOS. I installed the Budgie version on a dual-boot with a Manjaro install using a ssd-switch and having /home on a seperate HD. At first all things ran smoothy, but the other day, the Grub seemed wrecked as I only got the DOS message that there is no proper OS installed.

So I searched the Wiki and the help sites and found rafael-uy’s solution to re-install the grub (containing a mispelling though). Which worked…for a single day. The day after the next boot with DOS prompt ‘no proper OS installed’ failure message showed up. This time the solution didn’t work and I can’t start the dual-boot.

Side information is, that Reborn seemed to have installed a non-existant Windows UEFI entry, which is shown when I hit ‘F8’ to choose the drive for boot.

Reborn OS seemes quite interesting to me, a little bit like my ArcoLinux one, except the installer and repositories. However, if I can’t have a stable grub, there is no way to use it.

So, how to solve this? It seems to me, like as if the installed grub searches for a non-existant Windows entry and crashes the dual-boot grub every other day.



1 Like

So, no one has an idea how to solve?

As a first dirty measurment I patched Reborn grub with the Manjaro grub. That one works.

I have read about incompatibilities between different dual-boot Arch installations, so i guess this is one of that rare incidents.

But, it may also be an issue with your grub2 version. In that case, devs should look into it.

1 Like

Think the issue is manjaro grub tbh. I know manjaro grub can boot linux mint but mint can’t boot manjaro so it’s probably the same with rebornos. Manjaro do some grub modifications

1 Like

Well, I took your advice and did several testings now.

First, I installed Elementary OS at the position of Manjaro. The grub entry with both OS’ is found, Elementary OS started without an issue. But when I tried to start Reborn OS, I only got black screen.

Then I installed ArcoLinux at the very same position and after first re-start, I didn’t even get a grub. First view was the well known DOS prompt about ‘no proper OS installed’ failure.

Am still wondering how I got the Windows UEFI entry, while no Windows is installed, right after I installed Reborn OS as dual-boot. As I use several SSD’s in my SSD rack, to avoid incompatibilities, I only see this Windows entry whenever I use the dual-boot SSD from Reborn OS install.

1 Like

Hi @Kepos ,

When you get to the black screen, would you like to test if you can get to the tty by pressing Ctrl + Alt + F2 or Ctrl + Alt + Fn + F2 ? Also, it would help to see systemd logs after chrooting into the installed system. For live response and guidance, you can join the Discord Server :relaxed:.

1 Like

Hi @shivanandvp , thank you for the response.
The black screen occured when trying to access RebornOS while on dual-boot with Elementary. Unfortunately I’ve overpatched Elementary with ArcoLinux.
As for systemd logs on dual-boot ArcoLinux…well, I didn’t get beyond the DOS prompt. I may get there with the installation ISO, but don’t know how to get them. Thx for the Discord link, will take a look.

1 Like

I read that Manjaro does have a special GRUB. I was doing some reviewing on Arch based distros. You can’t really use Manjaro very well in dualboot situations is what it said because their GRUB does not always play nice with other Distros and just as was said install of another Distro their GRUB may not be able to find Manjaro.

Perhaps a reinstall of Reborn now that you overwrote Manjaro. I was fortunately when trying and testinng Manjaro doing it on external storage. Because I do recall when I tried to put something else it was like bits and parts
of Manjaro in the EFI boot etc would not go away. I just reformatted.

1 Like

Yeah, sounds familiar.

Have read about such issues, but never encountered them so far. They are telling about issues with other Arch based distributions and from my testings so far, I can tell that Manjaro works quite ok with non-Arch distros.

Tested a lot with @shivanandvp on Discord yesterday and we didn’t manage to get a working OS so far. We only tried to rescure and restore, but never reformatted.

As I do use /home on a seperate hard disk, fresh install isn’t a problem to me, while my settings are stored. This was my test-bed with dual-boot, while I do use single installations with my SSD-rack for my secured favorite distributions.

So, it seems I have to order me some more small SSD’s then… :stuck_out_tongue: …which might not be the best solution, but a functional.

Thx, for looking into it.

Sorry to say guys, but it seems dual-boot of Reborn OS with another Arch distribution seems wrecked.
As my chat with @shivanandvp on Discors brought up, this dual-boot is never been tested, instead of Windows and Reborn.

My testings so far included RebornOS Budgie as base installation on a switchable SSD. I never tested anything other than Arch so far, so this part may be unharmed.

I added one after the other Manjaro, ArcoLinux Deepin, RebornOS Gnome. In all circumstances, I was not able to pick the other dual-boot distribution from Grub, as it only produced black screen without a prompt or error notice. The only issue-free start was with ArcoLinux Deepin, but it produced a second Grub or Efi option, which I was able to choose over BIOS [F8], which is quite weird to show up this way.

It seems, that RebornOS has a basic issue when it comes to dual-boot setup with another Arch distribution. I’ve read something similar somewhere in the Manjaro forums, but am not sure about.

Hopefully this post may get someone from the team’s attention in the bug section.

Unfortunately, I have not been a Windows user for many years.
There is a post on our Wiki from a RebornOS member who has tried a dual installation of Windows with RebornOS. Perhaps it will be of some use to you:

Greetings and take care.

@Rafael , sorry, but I am posting about dual-boot with another Arch distribution, while you show me hints about dual-boot with Windows.

In fact, installing RebornOS brought me a non-installed Windows EFI entry in BIOS, when I start with [F8]. Probably you can give me explanation about this?