Can't install on metal (Live-USB)

I downloaded and tried Reborn on VirtualBox and it looked great! (tried the UKUI desktop). I loved it so much I wanted to install it on real metal. But, alas… :disappointed:

When it reaches target graphical interface it just simply stops.

Just to make sure it isn’t an Arch thing, I then booted another arch-based distro (using the same USB) and that one booted smoothly. I even compared the boot menu entries and they were the same (except for some details, of course).

My box has an Intel i7 and an older NVIDIA card (no longer supported, so I’m down to nouveau).

Hi @Aero9000 !

Welcome. When the booting process gets stuck, can you press Ctrl Alt F3 and login on the text console? From there you can share the installation logs. Connect to the internet (if you have not already), by running the command nmtui. Then run,

cat /var/log/install.log | nc 9999

You will receive a URL which you can share here.


There is no install.log file. During initial boot I never get a gui screen. :frowning:

The only way I can get to some sort of gui is by choosing the nomodeset option, but that gives me a 640x480 screen which is, basically, next to useless.

Then I decided to reboot and when the live-USB hung again, in the terminal I typed startx. The screen flashed a few times and now there is an Xorg log-file.

You don’t need a GUI. During boot you can see a message saying target graphical interface reached or something like that. Press Ctrl Alt F3 there to get a text-based console where you can login with your username and password (no GUI). Then you can follow the earlier instructions.

This is exactly what I did. But like I also wrote, there was no install.log file. I guess simply because I couldn’t start the install process.

If there is a text-based install possiblility, please point me to it. I’m really motivated to give reborn a try.

I apologize. Perhaps I did not understand what you meant. Does the ISO boot on bare metal? Were you able to get in the ISO at all?

No, I was not able to boot on bare metal.

The ISO never boots into a desktop or install. Mind you, the very same ISO image DOES boot on Virtualbox. So it is not a matter of a corrupted ISO. And also, the USB-drive is not defective, as I have been able to boot with that very USB-drive into other live-distros, since and before.

Ah. I get it now. Try each of the 8 different boot options in the Grub menu one by one. One of them is going to work most likely

Only the one nomodeset be booted only into a gui. But then I couldn’t get anywhere. Something like an error that the screen resolution was too small.

Can you share a photo or screenshot to look at what error you have with the GUI? That will give me a better idea. Also you can message live on Discord (RebornOS)

Well guess what? (Sorry for the long delay. :frowning: )

As a distro-hopper, today I attempted to install Manjaro on metal. Different distro, same shit. It never boots into a GUI.

So whatever it is, it’s coming from upstream – possibly Arch itself. But I ain’t got the energy nor the time to find out.

Nonetheless, keep up the good work! There are many across the Globe who really appreciate your time and efforts!!

Signing off…

Sorry you’re having troubles. It would be really helpful if you could provide some basic hardware specifics as to possibly help you and/or others who might be experiencing similar problems.

Along with hardware results from running inxi -F from a terminal via Live-USB before running the install knowing that it will probably fail, it will provide some important relevant information, the /var/log/install.log would also be helpful to see as well.

From terminal, run the following which will upload the results to the hosted site and be viewable from a web browser.

$ inxi -F | nc 9999
$ sudo cat /var/log/install.log | nc 9999

They’ve mentioned in another reply that install.log doesn’t exist since it can’t reach anything.

Hardware info is more relevant if the ISO does not boot or only can boot with nomodeset.

After installation, you can add nomodeset to grub commandline parameters from a tty (Ctrl Alt F3) to boot into a GUI next time. I can help you with how to do that.