Some of GTK-Applications produce screen noise as patterns

since approx. 2 month GTK-apps look disturbed with weird patterns .
( like Thunderbird, LibreOffice (fresh) are affected but NOT Firefox strangely )
Any hint to this, do I miss some GTK stuff ?
Thx in advance …

p.s. after resizing those windows for a few times, those patterns disappear until
I reopen a GTK app.


Could you try launching those apps from a terminal see if you get any error messages there?

Also, I found this online: Gentoo Forums :: View topic - [SOLVED] gtk under KDE: artifacts and window redraw problems . (They deleted a directory and logged in again to resolve their issue.)

deleted .kde4, restarted but no change.
Console start libreoffice produces no error messages.
Thunderbird says:

   (thunderbird:53537): Gtk-WARNING **: 00:35:38.067: Locale not supported by C library.
        Using the fallback 'C' locale.

(thunderbird:53537): Gtk-WARNING **: 00:35:38.656: Theme parsing error: gtk.css:127:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

…maybe I also should mention that I have 2 monitors connected to my PC

These messages seem pretty harmless. They are the kind that I see in my setup too.

There is something else going on. Do you run Wayland or X11 (sessions available to select at the login screen)

that is a good thought, unfortunately at least at login stays X11, …
it seems X11 indicated, not sure how to check for the session mode, just right now in the terminal,
but as I change my position to vertical I would check :sleeping: :slight_smile:

Hmm. Does the flickering persist when you temporarily turn off compositing?
System Settings > Display and Monitor > Compositor uncheck Enable compositor on startup and restart

that kind of solves the problem, but on the other hand I use computer only
for this reason, to see the compositor at work :slight_smile: :sleepy:

interestingly only LibreOffice and Thunderbird are affected, not Firefox or Chromium …

Thanks for giving me the idea with the compositor:,

I deactivated the “Hardware-Acceleration” - Option in Thunderbird, now it is working even
with Compositor ON. - is it OK to disable Hardware-Acceleration, or do I run in other problems with that?

And still, what to do with LibreOffice :slight_smile: ?

Hardware acceleration offloads work from the CPU to the GPU. No harm, but you may see a difference in performance depending on your hardware.

1 Like

I think this is a plasma issue, waiting for the KDE team to correct it…