Installation fails on virtual box

I have tried many desktop environments but all of them are failing I did manage to install it in actual hardware but unable to install it in my virtual machine


That is puzzling. @Rafael may be able to check Cnchi. I will check with them. Meanwhile, could you show me the output of

df -h

ls -ltrd /var/tmp/cnchi

You may be able to do sudo chmod 777 /var/tmp/cnchi and run the installer again. This gets erased after a reboot because the ISO is not persistent.

Filesystem      Size  Used Avail Use% Mounted on
dev             1.5G     0  1.5G   0% /dev
run             1.5G  165M  1.3G  12% /run
/dev/sr0        2.2G  2.2G     0 100% /run/archiso/bootmnt
cowspace         10G   41M   10G   1% /run/archiso/cowspace
/dev/loop0      2.0G  2.0G     0 100% /run/archiso/airootfs
airootfs         10G   41M   10G   1% /
tmpfs           1.5G   32K  1.5G   1% /dev/shm
tmpfs           1.5G  8.0K  1.5G   1% /tmp
tmpfs           299M  100K  299M   1% /run/user/1000

drwxr-xr-x 2 root root 60 Jul 19 16:34 /var/tmp/cnchi

Will try

@shivanandvp Btw Shivanan sounds like a tamil name. Are you tamil or from india?

Just as a confirmation, was the installer run with a sudo, like sudo Superuser privileges are necessary

I just opened the desktop file of the installer. I don’t necessarily have to use sudo with it right?

i did try opening the desktop file with sudo but the installer crashed after some time and logged out. I think i’ve tried to install for more than 10 times. I’ve had enough of this.

Error that occured in the last attempt

configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
none on /run/credentials/systemd-sysusers.service type ramfs (ro,nosuid,nodev,noexec,relatime,mode=700)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=305480k,nr_inodes=76370,mode=700,uid=1000,gid=984,inode64)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=984)  (
2022-07-20 02:48:08 [ERROR  ] Cannot wipe the filesystem of device /dev/sda: wipefs: error: /dev/sda: probing initialization failed: Device or resource busy  (
2022-07-20 02:48:08 [ERROR  ] 'Cannot wipe the filesystem of device /dev/sda: wipefs: error: /dev/sda: probing initialization failed: Device or resource busy'  (
2022-07-20 02:48:08 [ERROR  ] Traceback (most recent call last):  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/share/cnchi/src/misc/", line 98, in call
    output = subprocess.check_output(  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/lib/python3.9/", line 424, in check_output
    return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/lib/python3.9/", line 528, in run
    raise CalledProcessError(retcode, process.args,  (
2022-07-20 02:48:08 [ERROR  ] subprocess.CalledProcessError: Command '['wipefs', '-a', '/dev/sda']' returned non-zero exit status 1.  (
2022-07-20 02:48:08 [ERROR  ] 
During handling of the above exception, another exception occurred:  (
2022-07-20 02:48:08 [ERROR  ] Traceback (most recent call last):  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/share/cnchi/src/installation/", line 155, in run
    self.install_screen.run_format()  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/share/cnchi/src/pages/", line 254, in run_format  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/share/cnchi/src/installation/", line 748, in run
    self.run_mbr(part_sizes)  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/share/cnchi/src/installation/", line 520, in run_mbr
    wrapper.wipefs(device)  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/share/cnchi/src/installation/", line 49, in wipefs
    call(cmd, msg=err_msg, fatal=fatal)  (
2022-07-20 02:48:08 [ERROR  ]   File "/usr/share/cnchi/src/misc/", line 123, in call
    raise InstallError(msg)  (
2022-07-20 02:48:08 [ERROR  ] misc.extra.InstallError: 'Cannot wipe the filesystem of device /dev/sda: wipefs: error: /dev/sda: probing initialization failed: Device or resource busy'  (


From the errors, it seems like your storage is busy. I do not know much about Cnchi and it is in its end-of-life phase. Still waiting for @Rafael to check this.

Normally if an installation fails 2-3 times I would not try the same thing again. It would be a waste of time.

I have our new alpha ISO and installer based on Calamares that I just tested for 10 desktops. Would you like to try that instead? A fair warning that it is still not polished (some desktops start with a black background, the themes may be off), but it can easily be set up, and it gives a clean experience.

Which desktop would you be installing? The new installer is not yet tested for Cutefish, Regolith, i3, Openbox or enlightenment. Other desktops work fine-ish.

This is not officially released and still in alpha stage. So you may encounter minor bugs. Here is the ISO if you want to try it: rebornos_labs_xfce_minimal-2022.07.17-x86_64.iso - Google Drive

1 Like

After losing so many hours to this,
I believe i have found the real issue. It is the drive that i’m storing my .vdi files that seems to be causing the problem.
Thank you for your assistance.

I would like to suggest some changes to the new installer.

  1. Can you show a loading when the calamare package is being downloaded. It would seem like the button is not working for a while.

  2. Some dialog seems to popup after clicking install and then closes before i can read anything

  3. why pamac as a manjaro user i don’t even use pamac. It is slow compared to yay and the one thing that i hate the most is that it defaults to No when confirming if i want to install a package

  4. I do remember some people telling me that grub-customizer is dangerous. I created an application to replace it using pyqt called grub-editor which doesn’t edit /boot/grub/grub.cfg but edits /etc/default/grub/ maybe take a look at it. Actually i just wanted to install rebornOs to test that application in this OS tries to launch, but quits · Issue #2 · Thenujan-0/grub-editor · GitHub.

1 Like

Hi glad to see the issue was resolved. :slight_smile:

Thanks for your feedback.
the new installer has a progress indicator but perhaps we can have it show progress on downloading this is something we will look into.

Pamac is optional in the new installer and can be deselected there’s sadly not a lot of good graphical options on Arch linux at this moment

As for your grub customizer alternative I will take a look at it. it does make backups of files so as far as I’m aware it generally doesn’t break something but some distros may use custom configs and it may break in that case I don’t know.