Connecting to WiFi freezes my system


I have discovered that if I connect to any WiFi network from my laptop with RebornOS, seconds later the system freezes everything and I can only force shutdown the laptop.
The model / driver that I have installed is Realtek RTL8821CE. I also have a wired network connection and on that I don’t get any problems.
I have been lucky that I have the router so I needed to power it off while I forgot the WiFi connection otherwise at every startup the system would freeze.

This is the basic network information that I have:

[mmx@INV-7654-VV ~]$ ifconfig
enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        ether 70:b3:d5:16:98:eb  txqueuelen 1000  (Ethernet)
        RX packets 972  bytes 284766 (278.0 KiB)
        RX errors 0  dropped 7  overruns 0  frame 0
        TX packets 763  bytes 120320 (117.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 38  bytes 4159 (4.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 38  bytes 4159 (4.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 3e:ba:29:17:9d:12  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

[mmx@INV-7654-VV ~]$ 

also my kernel is:

[mmx@INV-7654-VV ~]$ uname -a
Linux INV-7654-VV 5.12.15-arch1-1 #1 SMP PREEMPT Wed, 07 Jul 2021 23:35:29 +0000 x86_64 GNU/Linux

Is there any hope for me to use this WiFi card with RebornOS? Is it incompatible with the system?
One thing I managed to find is something about Disabling Power Management that may help, still researching to see how I can do that, do you know by any chance if I can disable that feature and how?

EDIT: Managed to turn off power management in the WiFi card and now the system is no longer frozen.

Now… I would need to add this script at every computer boot/start-up. Would anyone be kind to let me know of how I could do that please? Or how to disable this wifi power management permanently? :smiley:

Thank you!

@laur It’s possible to put it into a systemd service for it to startup everytime. But that will be a hacky way to get things done. Before that, could you try the below?

sudo pacman -S networkmanager
sudo pacman -S --needed gedit
sudo gedit /etc/udev/rules.d/81-wifi-powersave.rules

Paste the below line:

ACTION=="add", SUBSYSTEM=="net", KERNEL=="wl*", RUN+="/usr/bin/iw dev $name set power_save off"

Save, exit, and reboot

Please let me know if this works :slightly_smiling_face:

1 Like


Thank you very much for your help!

Yes, it does seem indeed that this trick disables power save for my WiFi card at startup
After this and rebooting, I don’t see my system freezing right away like last time. I will test it out and see if it still freezes and will update you, but for now it’s ok.

It seems that for some reason this happens more often on WPA3-SAE WiFi than on the WPA2-AES WiFi that I am connected to, but may not be related to that.

Once again many thanks. Really appreciate it :slight_smile:

1 Like

Sure. Please let me know if your computer freezes again