Touchpad not working after installation + Freezing when connected to Wifi

Hi everyone.

I hope you can help me.

I couldn’t get the touchpad to work after installing RebornOS on one of my laptops. I was connected to the network/internet during installation and selected anything i could related to other devices.

I tried downloading synaptic packages, anything else related to touchpad, but unfortunately my touchpad still doesn’t respond.

Could you please help me get the right drivers or config for my touchpad? I can look into any details or info about the hardware if you direct me where to look.

Any help would be greatly appreciated.

Thank you very much!

Welcome to RebornOS.

To try to solve the problems of your touchpad, it would be interesting to know the model of your computer, to see if that way we can find a solution to your problem.

Meanwhile, we can offer you the following link to the Arch Linux Wiki, which can be very useful:

https://wiki.archlinux.org/title/Touchpad_Synaptics

The more information you can give us, the better it is to see if someone can find the solution to your problem.

We hope you are well. Greetings.

Hi. Thank you for coming by. :slight_smile:

My laptop model is ALLBOOK J from Allview.

Also, I just noticed apart from that now, after i connected to wifi, the laptop froze and now every time i start it, it freezes after a few seconds.

Will try to dig into that a bit to see what’s going on and to share with you.

I have a similar / identical laptop with windows 10 on it so if you need some specific hardware info i can try getting the info from there inside Windows, or from the live REBORNOS USB.

Also, just noticed now that on reborn os live medium the touchpad works, but only with finger input (tap and move), the buttons don’t respond.

And now as I’m testing, yes, it appears that reborn os freezes after connecting to wifi (wpa2-aes) on 5ghz . Wifi adapter is realtek 8821CE.

So to summarize, there is the WiFi freeze issue and the touchpad working on live medium but not after installation.

Hi @laur,

The below command will install libinput if you don’t already have it installed:

sudo pacman -S --needed libinput xf86-input-libinput xorg-xinput

Reboot your computer after this.

If this still does not solve your problem, we need more information. Please provide the output of the below commands:

dmesg | grep -i synaptics
xinput list

Please post here again if this does not resolve your issue :slightly_smiling_face:

Hi.

Thanks for coming back!
Regarding the freeze I managed to boot via LTS kernel and disable WiFi so for now I was able to boot.

Regarding the touch-pad, it still doesn’t work after the commands.

The output is:

[mmx@INV-7654-VV ~]$ sudo su
[root@INV-7654-VV mmx]# sudo pacman -S --needed libinput xf86-input-libinput xorg-xinput
warning: libinput-1.18.0-1 is up to date -- skipping
warning: xf86-input-libinput-1.1.0-1 is up to date -- skipping
warning: xorg-xinput-1.6.3-2 is up to date -- skipping
 there is nothing to do
[root@INV-7654-VV mmx]# dmesg | grep -i synaptics
[root@INV-7654-VV mmx]# xinput list
WARNING: running xinput against an Xwayland server. See the xinput man page for details.
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ xwayland-pointer:17                     	id=7	[slave  pointer  (2)]
⎜   ↳ xwayland-relative-pointer:17            	id=8	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ xwayland-keyboard:17                    	id=6	[slave  keyboard (3)]
[root@INV-7654-VV mmx]# 

Hi @laur,

Thanks for the information. Could you please perform two small checks for me?

  1. Open your Settings, find Touchpad settings and check if it is enabled. You may also verify that it is set up correctly.
  2. You may install and open hardinfo from the RebornOS Welcome application under the Utilities tab. Then within the application, see if your touchpad device is listed. It must be under Devices > Input Devices

The only info I can find is this. There doesn’t appear to be a setting to enable touchpad.
Currently using a USB mouse.

Hoping that it could be of some use. :slight_smile:

This is puzzling. I do not see your touchpad listed.

Please share the output of the below commands:

journalctl -b - 0 | grep -i touchpad
cat /proc/bus/input/devices | grep -i touchpad

Then try the below steps to update your system, install some WiFi drivers and regenerate intramfs:

sudo pacman -Syyu
sudo pacman -S rtl8821ce-dkms-git
sudo mkinitcpio -P

Then reboot.

[root@INV-7654-VV mmx]# journalctl -b -0 | grep -i touchpad
[root@INV-7654-VV mmx]# cat /proc/bus/input/devices | grep -i touchpad
[root@INV-7654-VV mmx]# sudo pacman -Syyu
:: Synchronizing package databases...
 Reborn-OS             278.1 KiB  1112 KiB/s 00:00 [######################] 100%
 core                  134.3 KiB   480 KiB/s 00:00 [######################] 100%
 extra                1565.9 KiB  6.37 MiB/s 00:00 [######################] 100%
 community               5.6 MiB  8.48 MiB/s 00:01 [######################] 100%
 multilib              149.7 KiB  2.44 MiB/s 00:00 [######################] 100%
:: Starting full system upgrade...
 there is nothing to do
[root@INV-7654-VV mmx]# sudo pacman -S rtl8821ce-dkms-git
warning: rtl8821ce-dkms-git-1.0.5.r124.g7a11dc9-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) rtl8821ce-dkms-git-1.0.5.r124.g7a11dc9-1

Total Installed Size:  30.16 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Running pre-transaction hooks...
(1/1) Remove upgraded DKMS modules
==> dkms remove --no-depmod -m rtl8821ce -v 1.0.5.r124.g7a11dc9 -k 5.10.49-1-lts
==> Unable to remove module rtl8821ce/1.0.5.r124.g7a11dc9 for kernel 5.12.15-arch1-1: Not found in dkms status output.
:: Processing package changes...
(1/1) reinstalling rtl8821ce-dkms-git              [######################] 100%
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Install DKMS modules
==> dkms install --no-depmod -m rtl8821ce -v 1.0.5.r124.g7a11dc9 -k 5.10.49-1-lts
==> dkms install --no-depmod -m rtl8821ce -v 1.0.5.r124.g7a11dc9 -k 5.12.15-arch1-1
Error! Bad return status for module build on kernel: 5.12.15-arch1-1 (x86_64)
Consult /var/lib/dkms/rtl8821ce/1.0.5.r124.g7a11dc9/build/make.log for more information.
==> Warning, `dkms install --no-depmod -m rtl8821ce -v 1.0.5.r124.g7a11dc9 -k 5.12.15-arch1-1' returned 10
==> depmod 5.12.15-arch1-1
==> depmod 5.10.49-1-lts
(3/3) Refreshing PackageKit...
[root@INV-7654-VV mmx]# sudo mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
==> Starting build: 5.10.49-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'fallback'
  -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts-fallback.img -S autodetect
==> Starting build: 5.10.49-1-lts
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-lts-fallback.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.12.15-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 5.12.15-arch1-1
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: xhci_pci
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful
[root@INV-7654-VV mmx]# 

This would be the output of the commands before reboot. Also rebooting now.
EDIT: finished rebooting. Touchpad still not working. Currently on LTS kernel as it allows me to boot with the WiFi card

EDIT 2: changed journalctl -b - 0 to journalctl -b -0 as the command was unrecognized due to the last space.

EDIT 3: Tried again with a fresh live USB of RebornOS, touchpad not usable in there either.

Also got an identical laptop with windows 10 on it… Got info from touchpad like this… Does it help?

HID\HTIX5288&COL01\5&148E01A2&1&0000

1 Like

Hey… Sorry for the spam… I have a quick update.
It seems that it is due to the kernel selection.

I have selected the normal (non-LTS) kernel and now both WiFi and touchpad work ! :smiley:
Since I am a Linux noob better not mess around any longer - as long as they work I am golden.

The new output would be:

=====================================================

[root@INV-7654-VV mmx]# journalctl -b -0 | grep -i touchpad
Jul 12 20:58:46 INV-7654-VV kernel: input: HTIX5288:00 093A:0255 Touchpad as /devices/pci0000:00/0000:00:17.3/i2c_designware.7/i2c-7/i2c-HTIX5288:00/0018:093A:0255.0001/input/input7
Jul 12 20:58:46 INV-7654-VV kernel: input: HTIX5288:00 093A:0255 Touchpad as /devices/pci0000:00/0000:00:17.3/i2c_designware.7/i2c-7/i2c-HTIX5288:00/0018:093A:0255.0001/input/input17
Jul 12 20:58:47 INV-7654-VV touchegg[380]: libinput error: event7  - HTIX5288:00 093A:0255 Touchpad: kernel bug: clickpad with right button, assuming it is not a clickpad
Jul 12 20:58:47 INV-7654-VV touchegg[380]:         Name: HTIX5288:00 093A:0255 Touchpad
Jul 12 20:58:48 INV-7654-VV org.gnome.Shell.desktop[570]: libinput error: event7  - HTIX5288:00 093A:0255 Touchpad: kernel bug: clickpad with right button, assuming it is not a clickpad
Jul 12 20:59:29 INV-7654-VV gnome-shell[918]: libinput error: event7  - HTIX5288:00 093A:0255 Touchpad: kernel bug: clickpad with right button, assuming it is not a clickpad
[root@INV-7654-VV mmx]# cat /proc/bus/input/devices | grep -i touchpad
N: Name="HTIX5288:00 093A:0255 Touchpad"
[root@INV-7654-VV mmx]# 
[root@INV-7654-VV mmx]# uname -a
Linux INV-7654-VV 5.12.15-arch1-1 #1 SMP PREEMPT Wed, 07 Jul 2021 23:35:29 +0000 x86_64 GNU/Linux

=====================================================

1 Like

@laur That’s good to know! Is this a relatively newer device? I wonder why the later Linux kernels work well with it.

You can mark your own post as a solution so that others can find it. Thanks :slightly_smiling_face:

Well, I believe even if it is an entry model laptop, it has recently been released.

https://www.allview.ro/allbook-j.html

Here is the website of the product if you are interested to find out about the specs.
And if you think further info for this hardware would be useful for RebornOS database, I would gladly share that with you. (e.g. via an export from System Profiler).

Also it is an Intel system, and the CPU is a quad core so not the most recent ones, usually Linux systems work OK on Intel CPUs.

There is a tool available in RebornOS by default, which is inxi. The use of inxi can be observed in our Wiki:

Using it from the terminal, you will be able to obtain a wide variety of information about your system.

You may want to share the result of some of the examples shown on the Wiki, so that we can start a database of RebornOS compatible computers.

Glad you got your computer to work properly.

Greetings and take care of yourself.

Hi. I have run the following command (I believe it gives detailed information):

[root@INV-7654-VV mmx]# inxi -A -B -c -C -d -D -E -f -F -G -I -j -l -L -m -M -n -N -o -p -s -S -t -u
System:
  Host: INV-7654-VV Kernel: 5.12.15-arch1-1 x86_64 bits: 64 
  Console: tty pts/0 Distro: RebornOS Linux 
Machine:
  Type: Laptop System: Allview product: Allbook J v: N/A 
  serial: ABJ1200775689 
  Mobo: N/A model: N/A serial: N/A UEFI: American Megatrends 
  v: QPTC-BI-15.6-X133GRX170-GM60D-007-C date: 12/16/2020 
Battery:
  ID-1: BAT0 charge: 30.6 Wh (67.1%) condition: 45.6/45.6 Wh (100.0%) 
Memory:
  RAM: total: 7.59 GiB used: 2.44 GiB (32.2%) 
  RAM Report: 
  missing: Required tool dmidecode not installed. Check --recommends 
CPU:
  Info: Quad Core model: Intel Celeron J4125 bits: 64 type: MCP cache: 
  L2: 4 MiB 
  Speed: 765 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 765 2: 1608 
  3: 751 4: 2504 
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est 
  flexpriority fpu fsgsbase fxsr ht ibpb ibrs ibrs_enhanced ida intel_pt 
  lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc 
  nopl nx pae pat pbe pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse 
  pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap 
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vme vmx vnmi vpid 
  x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
Graphics:
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel 
  Device-2: Alcor Micro SHUNCCM2MP type: USB driver: uvcvideo 
  Display: server: X.Org 1.21.1.2 driver: loaded: i915 
  note: n/a (using device driver) resolution: 1920x1080~60Hz 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio 
  driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.12.15-arch1-1 running: yes 
  Sound Server-2: PulseAudio v: 14.2 running: yes 
  Sound Server-3: PipeWire v: 0.3.31 running: yes 
Network:
  Device-1: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  driver: rtw_8821ce 
  IF: wlp1s0 state: down mac: 9e:2c:d7:d5:c4:3a 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: 70:b3:d5:16:98:eb 
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb 
  Report: rfkill ID: hci0 state: up address: see --recommends 
Logical:
  Message: No logical block device data found. 
Drives:
  Local Storage: total: 238.47 GiB used: 19.97 GiB (8.4%) 
  ID-1: /dev/sda model: W800S 256GB SSD size: 238.47 GiB 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / size: 115.84 GiB used: 19.26 GiB (16.6%) fs: ext4 dev: /dev/sda2 
  label: system uuid: aae40a84-8ebc-4c0a-911e-a14f05987373 
  ID-2: /boot/efi size: 93.9 MiB used: 285 KiB (0.3%) fs: vfat 
  dev: /dev/sda1 label: EFI uuid: C803-9957 
  ID-3: /home size: 110.26 GiB used: 729.1 MiB (0.6%) fs: ext4 
  dev: /dev/sda3 label: data uuid: 0f68aeae-7ee4-4ff1-8874-255023fc533b 
Swap:
  Alert: No swap data was found. 
Unmounted:
  ID-1: /dev/sda4 size: 7.54 GiB fs: swap label: VIRTUALMEM 
  uuid: bc60d59f-b0be-4fcf-af8b-2b0fe2dc1023 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Processes:
  CPU top: 5 of 254 
  1: cpu: 28.1% command: firefox pid: 35702 
  2: cpu: 11.5% command: gnome-shell pid: 21023 
  3: cpu: 10.2% command: firefox pid: 35999 
  4: cpu: 5.2% command: firefox pid: 36190 
  5: cpu: 4.7% command: firefox pid: 35868 
  Memory top: 5 of 254 
  1: mem: 435.4 MiB (5.6%) command: firefox pid: 35702 
  2: mem: 272.4 MiB (3.5%) command: gnome-shell pid: 21023 
  3: mem: 201.9 MiB (2.5%) command: firefox pid: 35868 
  4: mem: 199.1 MiB (2.5%) command: firefox pid: 35838 
  5: mem: 194.5 MiB (2.5%) command: firefox pid: 35999 
Info:
  Processes: 254 Uptime: 1h 38m Shell: Bash inxi: 3.3.04 

With hope that it will be useful and thank you again for your valuable help! :slight_smile:

Hi.

As an update, I still get intermittent results with the touchpad, sometimes it works, sometimes not. Tried both with LTS kernel and with the normal kernel, same results.

I am thinking to try Kernel Manager to select an older kernel.
Do you think that may work on the longer term or is it better that I don’t change it?

If that is not a good idea, I will try different things to see what else works for the touchpad as a permanent fix.

Thank you!

@laur Unless you are using a kernel with long term support (LTS), using an older kernel might be a security risk, depending on how old it is. Perhaps you can submit a bug report / issue on the kernel :thinking:

Hi.

I would like to post an update for this.
It may seem that the touchpad issue has been fixed for now.

How? A switch from BIOS.

However it was not as easy as it would seem. Chinese would seem like a child’s play to learn compared to my BIOS settings, even with my experience.

Basically I changed the mode of the touchpad to something else (Don’t even know what, how or why), just selected device Elan Tech instead of auto from BIOS and now it seems the system responds to the touchpad. Also it appears in xinput:

I hope this will fix the issue permanently. 2 restarts in and touchpad is still working.

L.E. It seems the fix was not permanent, also tried this one:

So far it works so we will see…

1 Like