Can't install Cinnamon since grub update issue

I haven’t used RebornOS in a while and thought I’d install from the latest iso.
However since the latest grub issue I can’t figure out how to successfully install along with the cinnamon desktop. In order to install cinnamon I have to do an online install and even if I uncheck the update button after the install it has updated grub and I have no video just before the login screen. At this point I am unable to reinstall grub and its config so my install is dead. The only way I have found to get around this is to physically unhook my network cable and do an offline install of XFCE. Then I am able to reboot and reinstall grub and config per the grub update warning. This is not how I want to do it as I want only cinnamon and not all the XFCE stuff. Is there a way around this problem? Also why is RebornOS the only Arch based distro that is affected by this issue? Manjaro, Arco, Arch (vanilla), were not affected I don’t believe. Please help. TIA

Hi @Ercouper! :blush:

Do you not see a grub screen at all? That is strange. For those who do new installations online (with update), there should be no problems and should not need any manual steps. Would you like to give some more details? Like do you use Nvidia hardware? What is the first thing you see when you boot up after an online installation?

I do not use Nvidia drivers, I use AMD/ATI open source drivers with my Radeon HD 4530/4570 card.
When I reboot after the install I see the normal Grub screen but after the timeout I loose video before the login screen appears. If I do an offline install with network unplugged (& XFCE of course) it reboots fine and the problem doesn’t show up until I update. Reinstalling again the same way and applying the grub re-install and config b4 updating and everything is fine. I’ve never had this happen with my other Arch based distro installs. Strange… I might also mention that my grub is legacy and not efi.

Thanks for the information. Checking if there are any upstream bugs


Do you see the same black screen if you choose an entry on the Grub menu before the timeout? If yes, then perhaps grub is switching to quiet mode possibly due to a new incompatible configuration of updated Grub.

If you can test choosing a menu entry before timeout and let me know, we can push out an update to the installer to fix this behavior for the new Grub configuration.

Yes, I am able to select normal boot or advanced options but then the resulting blank screen with “no video” message on my monitor appears with either selection.
To help rule out possibilities I am going to try an online install on one of my secondary pc’s to see if the result is the same. Thanks for trying to help me figure this out. :slightly_smiling_face:

No problem. I want to ensure that this won’t be a problem in the future. I will be watching this thread

I did an online install on another AMD pc, let it update and rebooted to find that there was no issues.
I took the HD and plugged it into my main pc to find the same no video problem. It’s as if there is a driver issue somehow. Since no one else seems to be complaining with the same problem I’ll continue to try and figure out what is causing this odd behavior and post any findings.


If you moved your hard-drive and your computer had no issues booting, then does the problem only arise with your main hard drive?

• Did you choose UEFI or Legacy Boot for the secondary hard drive? How does it compare with the main computer’s installation? You can check both devices to see if any of them has an EFI partition (with the esp boot flag) by opening up the gparted app.
• Is the partition layout for the secondary hard drive GPT or MBR? Is it different from the main computer’s hard drive? You can check both devices by running

sudo fdisk -l

to check the partition layouts

I took the drive from my secondary pc which I did the online install on & which booted fine & plugged it into my hot-swap drive slot on my main pc to find that I had the same no video problem. Returning it to my secondary pc it works fine. Both pc’s are legacy boot. It’s the same drive which I have been moving from pc to pc and is MBR.

Are the GPUs different between your main and secondary PC?

I believe that they are and I think the refresh rates are different between the monitors also…if that would make any difference. It sure seems like a video driver issue but not sure what would have changed during updates. I’m going to do an offline xfce install tomorrow and update it after first reboot to see if the problem surfaces. If so, I’m going to do another offline install and do the grub re-install and config. then reboot and see if the problem is gone. I’m beginning to think that the problem may not be a result of the grub problem (?). I just need to make sure one way or the other.

I think it is inefficient to do multiple installs.

I believe that the offline installation is working because of all the drivers it has, and not because of having an older grub.

Offline installation reflects what is on the ISO, and the ISO has all possible drivers required for various hardware that we plan to support.

Currently on Online installation, you can manually select extra drivers under the advanced page, but we are figuring out automation for the driver installation.

If you can run inxi -G on your main computer, I can suggest the packages to install on there. When we automate driver installation, we won’t need to do this anymore. But I am curious what the current issue is and would like to do everything possible to fix it on the installer.

You are correct. My problem was a video driver issue. I didn’t realize that the online install had less drivers available by default than the iso contained. That was the problem and why the offline install worked. I did another online install and selected all ATI & mesa drivers under advanced options and the install worked without issues. Now when I run inxi -G I get…

[ben@rebornos-pc ~]$ inxi -G
  Device-1: AMD RV710/M92 [Mobility Radeon HD 4530/4570/545v] driver: radeon
    v: kernel
  Display: x11 server: v: with: Xwayland v: 22.1.6 driver: X:
    loaded: radeon unloaded: modesetting dri: r600 gpu: radeon
    resolution: 1920x1080~60Hz
  API: OpenGL v: 3.3 Mesa 22.2.3 renderer: AMD RV710 (DRM 2.50.0 /
    6.0.12-arch1-1 LLVM 14.0.6)

So…everything is great now and thanks for your help and patience in helping me figure out the solution to my problem. Much appreciated! :smile:

1 Like

No problem. The online installation starts out lean because it can. But we will have to double down on a solution for automatic driver installation so that you only start with drivers that you do need.