RebornOS grub does not see the other operating systems

RebornOS, grub does not see the other operating systems.

Correction of the problem.

Open with sudo nano / etc / default / grub
and I added GRUB_DISABLE_OS_PROBER =" false
Save and close the file.
Finally I ran grub-mkconfig -o / boot / grub / grub.cfg
and it worked.

Hi @ste. We are aware. Grub does not run os-prober by default. The same is true in other Arch based distros as well (at least when I checked). However, we may enable os-prober in the future, considering a lot of the users use it anyway.

Also, below are the correct instructions:

Follow the below steps on RebornOS:

  1. Install os-prober:
sudo pacman -S --needed os-prober
  1. Enable os-prober in Grub:
sudo gedit /etc/default/grub

And uncomment/edit/add this entry:


Make sure that there is no # before the entry.
Save the file and exit.

  1. Regenerate grub.cfg and reboot:
sudo grub-mkconfig -o /boot/grub/grub.cfg

hi @shivanandvp. I understand what you are saying, but on a laptop I have win7 for professional reasons and ReborOS, so I needed a solution and after searching I came up with it.

Thanks anyway
Keep up the good work