Any plans for an ARM (U)EFI image?

I have a Phytium D2000 ARM computer with an AMD RX550 GPU.
I have been able to install Debian, Ubuntu, Fedora and Alma on it.
So far every distro with an ARM (U)EFI image boots.

The Phytium D2000 is very rare outside of China, but it seems that (U)EFI images for ARM are not that rare.
Do you have any plans for an ARM (U)EFI image?

you can try putting the generic qcow2 image onto a usb/ssd and boot from it
but idk how that will work. We are going to be working on UEFI isos and more soon

1 Like

I converted the qcow2 image with qemu-img.
It creates a 42 GB image, which seems a bit excessive.
Luckily I have a USB stick with 380 MB/s write speed.

I got an error about some jpg file, but it does boot on my Phytium D2000.
How do I install to my internal SSD?
I can put the SSD in a USB enclosure, but I prefer to work with an installer.

Do you know how i can get my hands on a machine like that? it would greatly help me with making an arm iso

They are not cheap (€589.75 excluding shipping/duties), but it looks like you can still order the last units.

But isn’t it possible to create a VM with (U)EFI?

People are also working on UEFI on the Radxa Rock 5B, but there’s no guarantee it will work properly. Although it is possible to boot Windows for ARM on it.

So perhaps the Windows devices with Snapdragons might also be an option.
RebornOS gets to the GRUB(?) menu on my Samsung Galaxy Book Go with Snapdragon (SD) 7c Gen 2.

I just received the 5G model with SD 8cx Gen 2 and it seems kernel 6.3 has support for it. And it seems kernel 5.20 has support for SD 8cx Gen 3, but it seems it’s not so trivial to get Linux booting on those devices.

If you only need a device for a couple of months, to set up your build scripts (or something like that), and you live in the EU, I’m willing to loan my device. Send me a PM if needed.

woweee 600 euros. Rock 5B isnt powerfull enough to test isos + bare metal is faster and easier and has more real life scenarios. Also Virtualization on rock 5B is tricky (need to use qemu)

It looks like the package manager isn’t working. It complains there are no servers configured for repository.
Weird thing is, that it does show updates, but I can’t install them.

I will check on this asap you can check /etc/pacman.conf
sudo rate-mirrors --allow-root --save=/etc/pacman.d/mirrorlist archarm

I had overwritten the USB stick with another image, so I delayed the test.
Today I wrote the image again and tried the update.
Now it works, so I’m not sure what the problem was.

do you have discord to join ours so we can communicate easier?
also im getting one of the phyntium machines

I just registered a Discord account and I think I’m on the RebornOS Discord server. I only see the Welcome channel.
Cool that you are getting a Phytium computer. Do note that you will need a USB ethernet or wifi adapter. The ethernet port doesn’t work with Linux yet.

Add me as a friend Pandaa#0123